about summary refs log tree commit diff
path: root/ci-builds.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ci-builds.nix')
-rw-r--r--ci-builds.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/ci-builds.nix b/ci-builds.nix
new file mode 100644
index 000000000000..cbed7b87d1a6
--- /dev/null
+++ b/ci-builds.nix
@@ -0,0 +1,37 @@
+# This file defines the derivations that should be built by CI.
+#
+# The plan is still to implement recursive tree traversal
+# automatically and detect all derivations that have `meta.enableCI =
+# true`, but this is currently more effort than it would save me.
+
+with (import ./default.nix {}); [
+  fun.amsterdump
+  fun.gemma
+  fun.quinistry
+  fun.watchblob
+  fun.wcl
+  lisp.dns
+  nix.buildLisp.example
+  nix.yants.tests
+  ops."posix_mq.rs"
+  ops.besadii
+  ops.journaldriver
+  ops.kms_pass
+  ops.kontemplate
+  ops.mq_cli
+  ops.nixos.camdenSystem
+  third_party.cgit
+  third_party.git
+  third_party.lisp # will build all third-party libraries
+  third_party.nix
+  tools.cheddar
+  tools.emacs
+  web.blog
+  web.cgit-taz
+  web.tvl
+
+  # Nugget is not currently built because it depends on various things
+  # (such as chromium-vaapi) that don't work in CI.
+  #
+  # ops.nixos.nuggetSystem
+]