about summary refs log tree commit diff
path: root/buildGo.nix
diff options
context:
space:
mode:
Diffstat (limited to 'buildGo.nix')
-rw-r--r--buildGo.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/buildGo.nix b/buildGo.nix
index b5a6ba2b3a53..c03c30bef1a0 100644
--- a/buildGo.nix
+++ b/buildGo.nix
@@ -70,7 +70,7 @@ let
     mkdir -p $out/${path}
     ${srcList path (map (s: "${s}") srcs)}
     ${go}/bin/go tool compile -o $out/${path}.a -trimpath=$PWD -trimpath=${go} -p ${path} ${includeSources uniqueDeps} ${spaceOut srcs}
-  '') // { goDeps = uniqueDeps; };
+  '') // { goDeps = uniqueDeps; goImportPath = path; };
 
   # Build a Go library out of the specified protobuf definition.
   proto = { name, proto, path ? name, extraDeps ? [] }: (makeOverridable package) {