about summary refs log tree commit diff
path: root/buildGo.nix
diff options
context:
space:
mode:
Diffstat (limited to 'buildGo.nix')
-rw-r--r--buildGo.nix14
1 files changed, 2 insertions, 12 deletions
diff --git a/buildGo.nix b/buildGo.nix
index 12504ce571..bf8625c1b4 100644
--- a/buildGo.nix
+++ b/buildGo.nix
@@ -123,18 +123,8 @@ let
       paths = [ gopathSrc gopathPkg ];
     }) // { goDeps = uniqueDeps; };
 
-  # Protobuf & gRPC integration requires these dependencies:
-  proto-go-src = fetchFromGitHub {
-    owner = "golang";
-    repo = "protobuf";
-    rev = "ed6926b37a637426117ccab59282c3839528a700";
-    sha256 = "0fynqrim022x9xi2bivkw19npbz4316v4yr7mb677s9s36z4dc4h";
-  };
-
-  goProto = external {
-    path = "github.com/golang/protobuf";
-    src = proto-go-src;
-    deps = [];
+  protoLibs = import ./proto.nix {
+    inherit external;
   };
 in {
   # Only the high-level builder functions are exposed