about summary refs log tree commit diff
path: root/blog/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'blog/default.nix')
-rw-r--r--blog/default.nix11
1 files changed, 3 insertions, 8 deletions
diff --git a/blog/default.nix b/blog/default.nix
index aaece3366876..fd35570a322a 100644
--- a/blog/default.nix
+++ b/blog/default.nix
@@ -1,15 +1,10 @@
-{
-  nixpkgs ? import <nixpkgs> {},
-  depot ? import <depot> {},
-  briefcase ? import <briefcase> {},
-  ...
-}:
+{ pkgs, depot, briefcase, ... }:
 
 let
-  injections = nixpkgs.writeText "injections.lisp" ''
+  injections = pkgs.writeText "injections.lisp" ''
     (in-package #:server)
     (setq *path-to-posts* "${./posts}")
-    (setq *pandoc-bin* "${nixpkgs.pandoc}/bin/pandoc")
+    (setq *pandoc-bin* "${pkgs.pandoc}/bin/pandoc")
     (setq *html-template* "${./src/index.html}")
   '';
 in depot.nix.buildLisp.program {