about summary refs log tree commit diff
path: root/advent-of-code/writePythonBin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'advent-of-code/writePythonBin.nix')
-rw-r--r--advent-of-code/writePythonBin.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/advent-of-code/writePythonBin.nix b/advent-of-code/writePythonBin.nix
new file mode 100644
index 000000000000..1730edb2ebe4
--- /dev/null
+++ b/advent-of-code/writePythonBin.nix
@@ -0,0 +1,18 @@
+{ pkgs ? import <nixpkgs> {}, ... }:
+
+{ name, deps, src }:
+
+let
+  inherit (pkgs) pythonPackages writeTextFile;
+  inherit (builtins) toFile;
+
+in writeTextFile {
+  inherit name;
+  executable = true;
+  destination = "/bin/${name}";
+
+  text = ''
+    #!/bin/sh
+    ${pkgs.python3}/bin/python3 ${src}
+  '';
+}