about summary refs log tree commit diff
path: root/adho-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'adho-configuration.nix')
-rw-r--r--adho-configuration.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/adho-configuration.nix b/adho-configuration.nix
index a36bc264b1..c08ec73500 100644
--- a/adho-configuration.nix
+++ b/adho-configuration.nix
@@ -1,5 +1,5 @@
 # Local configuration for 'adho' (Thinkpad T470s)
-{ config, ...}:
+{ config, pkgs, ...}:
 
 {
   boot.initrd.luks.devices.adho.device = "/dev/disk/by-uuid/722006b0-9654-4ea1-8703-e0cf9ac1905e";
@@ -7,6 +7,11 @@
   services.xserver.videoDrivers = [ "intel" ];
   programs.light.enable = true;
 
+  # Attempt to get Steam & co to run:
+  hardware.opengl.driSupport32Bit = true;
+  hardware.pulseaudio.support32Bit = true;
+  environment.systemPackages = [ pkgs.steam ];
+
   networking = {
     hostName = "adho";
     wireless.enable = true;