about summary refs log tree commit diff
path: root/adho-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'adho-configuration.nix')
-rw-r--r--adho-configuration.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/adho-configuration.nix b/adho-configuration.nix
index 5374f62fd6..a9328925ab 100644
--- a/adho-configuration.nix
+++ b/adho-configuration.nix
@@ -28,4 +28,10 @@
   };
 
   hardware.bluetooth.enable = true;
+
+  # Configure POSIX queue limits (for work)
+  systemd.tmpfiles.rules = let mqueue = "/proc/sys/fs/mqueue"; in [
+    "w ${mqueue}/msgsize_max - - - - ${toString (64 * 1024)}"
+    "w ${mqueue}/msg_max     - - - - 50"
+  ];
 }