about summary refs log tree commit diff
path: root/absl/types/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'absl/types/CMakeLists.txt')
-rw-r--r--absl/types/CMakeLists.txt15
1 files changed, 14 insertions, 1 deletions
diff --git a/absl/types/CMakeLists.txt b/absl/types/CMakeLists.txt
index fd71f38b85ee..f51d126f8160 100644
--- a/absl/types/CMakeLists.txt
+++ b/absl/types/CMakeLists.txt
@@ -20,6 +20,7 @@ list(APPEND TYPES_PUBLIC_HEADERS
   "bad_optional_access.h"
   "optional.h"
   "span.h"
+  "variant.h"
 )
 
 
@@ -95,7 +96,19 @@ absl_library(
     bad_optional_access
 )
 
-
+# variant library
+absl_library(
+  TARGET
+    absl_variant
+  SOURCES
+    "bad_variant_access.h" "bad_variant_access.cc" "variant.h" "internal/variant.h"
+  PUBLIC_LIBRARIES
+    absl::base absl::meta absl::utility
+  PRIVATE_COMPILE_FLAGS
+    ${ABSL_EXCEPTIONS_FLAG}
+  EXPORT_NAME
+    variant
+)
 
 #
 ## TESTS