about summary refs log tree commit diff
path: root/absl/types/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'absl/types/CMakeLists.txt')
-rw-r--r--absl/types/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/absl/types/CMakeLists.txt b/absl/types/CMakeLists.txt
index 8afde466de8c..910c099a94ab 100644
--- a/absl/types/CMakeLists.txt
+++ b/absl/types/CMakeLists.txt
@@ -172,12 +172,11 @@ absl_cc_library(
     optional
   HDRS
     "optional.h"
-  SRCS
-    "optional.cc"
   COPTS
     ${ABSL_DEFAULT_COPTS}
   DEPS
     absl::bad_optional_access
+    absl::base_internal
     absl::config
     absl::core_headers
     absl::memory
@@ -297,7 +296,8 @@ absl_cc_test(
 )
 
 # TODO(cohenjon,zhangxy) Figure out why this test is failing on gcc 4.8
-if(CMAKE_COMPILER_IS_GNUCC AND CMAKE_CXX_COMPILER_VERSION VERSION_GREATER 4.9)
+if(CMAKE_CXX_COMPILER_ID STREQUAL "GNU" AND CMAKE_CXX_COMPILER_VERSION VERSION_LESS 4.9)
+else()
 absl_cc_test(
   NAME
     variant_exception_safety_test