about summary refs log tree commit diff
path: root/absl/container/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'absl/container/CMakeLists.txt')
-rw-r--r--absl/container/CMakeLists.txt19
1 files changed, 15 insertions, 4 deletions
diff --git a/absl/container/CMakeLists.txt b/absl/container/CMakeLists.txt
index 3c2735ffcf2e..9f78100468a5 100644
--- a/absl/container/CMakeLists.txt
+++ b/absl/container/CMakeLists.txt
@@ -454,6 +454,16 @@ absl_cc_library(
 
 absl_cc_library(
   NAME
+    have_sse
+  HDRS
+    "internal/have_sse.h"
+  COPTS
+    ${ABSL_DEFAULT_COPTS}
+  PUBLIC
+)
+
+absl_cc_library(
+  NAME
     node_hash_policy
   HDRS
     "internal/node_hash_policy.h"
@@ -496,15 +506,16 @@ absl_cc_library(
   COPTS
     ${ABSL_DEFAULT_COPTS}
   DEPS
+    absl::bits
     absl::compressed_tuple
+    absl::config
     absl::container_memory
+    absl::core_headers
+    absl::endian
     absl::hash_policy_traits
     absl::hashtable_debug_hooks
+    absl::have_sse
     absl::layout
-    absl::bits
-    absl::config
-    absl::core_headers
-    absl::endian
     absl::memory
     absl::meta
     absl::optional