about summary refs log tree commit diff
path: root/absl/base/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'absl/base/CMakeLists.txt')
-rw-r--r--absl/base/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/absl/base/CMakeLists.txt b/absl/base/CMakeLists.txt
index 202003e60e60..3c580d434941 100644
--- a/absl/base/CMakeLists.txt
+++ b/absl/base/CMakeLists.txt
@@ -130,6 +130,29 @@ absl_library(
 
 absl_cc_library(
   NAME
+    config
+  HDRS
+    "config.h"
+    "policy_checks.h"
+  PUBLIC
+)
+
+absl_cc_library(
+  NAME
+    core_headers
+  HDRS
+    "attributes.h"
+    "macros.h"
+    "optimization.h"
+    "port.h"
+    "thread_annotations.h"
+  DEPS
+    absl::config
+  PUBLIC
+)
+
+absl_cc_library(
+  NAME
     spinlock_wait
   SRCS
     "internal/spinlock_wait.cc"