about summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 99ec7f741209..2b44a56a6064 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,10 @@
 SUBDIRS = externals src scripts corepkgs doc
 
-EXTRA_DIST = substitute.mk nix.spec
+EXTRA_DIST = substitute.mk nix.spec nix.spec.in
 
-rpm: dist
+include ./substitute.mk
+
+nix.spec: nix.spec.in
+
+rpm: nix.spec dist
 	rpm $(EXTRA_RPM_FLAGS) -ta $(distdir).tar.gz