about summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index cb50401357..720279460a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,3 +10,16 @@ rpm: nix.spec dist
 
 relname:
 	echo -n $(distdir) > relname
+
+install-data-local: init-state
+
+if INIT_STATE
+init-state:
+	$(INSTALL) -d $(DESTDIR)$(localstatedir)/nix
+	$(INSTALL) -d $(DESTDIR)$(localstatedir)/nix/db
+	$(INSTALL) -d $(DESTDIR)$(localstatedir)/log/nix
+	$(INSTALL) -d $(DESTDIR)$(prefix)/store
+#	$(bindir)/nix-store --init
+else
+init-state:
+endif
\ No newline at end of file