about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 6 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 5f54546a39d5..60247f3e666e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,7 +3,11 @@ name = "crimp"
 version = "0.1.0"
 authors = ["Vincent Ambo <mail@tazj.in>"]
 
+[features]
+default = [ "json" ]
+json = [ "serde", "serde_json"]
+
 [dependencies]
 curl = "0.4"
-serde = "1.0"
-serde_json = "1.0"
+serde = { version = "1.0", optional = true }
+serde_json = { version = "1.0", optional = true }