about summary refs log tree commit diff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c17806cc9a04..6163a103d44e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -137,6 +137,10 @@ function (googleapis_cpp_short_name var proto)
     set("${var}" "${short_name}" PARENT_SCOPE)
 endfunction ()
 
+# Create a single source proto library.
+#
+# - proto: the filename for the proto source.
+# - (optional) ARGN: proto libraries the new library depends on.
 function (googleapis_cpp_add_library proto)
     googleapis_cpp_short_name(short_name "${proto}")
     google_cloud_cpp_grpcpp_library(googleapis_cpp_${short_name}