about summary refs log tree commit diff
path: root/zoo/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-08-13T21·22+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-08-20T10·26+0100
commitf895cb417a7a397e9ddac7d2be7683e57e3cb1fb (patch)
tree7b1b5e6f68174bb86d6192e04348c92550ad334d /zoo/shell.nix
parent3fdfa14355088af602877153b49a85a5941fe879 (diff)
Move shift-time into top-level //zoo
I'm still unsure whether or not this is a good idea, but experimenting is a good
way to find out!
Diffstat (limited to 'zoo/shell.nix')
-rw-r--r--zoo/shell.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/zoo/shell.nix b/zoo/shell.nix
new file mode 100644
index 000000000000..465f0b05c1ba
--- /dev/null
+++ b/zoo/shell.nix
@@ -0,0 +1,10 @@
+let
+  briefcase = import /home/wpcarro/briefcase {};
+in briefcase.buildHaskell.shell {
+  deps = hpkgs: with hpkgs; [
+    hspec
+    rio
+    string-conversions
+    servant-server
+  ];
+}