about summary refs log tree commit diff
path: root/zoo/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-08-14T13·57+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-08-20T10·26+0100
commit375c4a4c857a5a5c56a9021ed721752288a3a357 (patch)
tree274cc0178ae7a06d9aca770e9c8a06ebf973cc3f /zoo/shell.nix
parent7e2dcc97cc98e22207c38026731b21472259dd18 (diff)
Restore shell.nix
I believe `use_nix` looks for shell.nix and then default.nix files, so I was
wrong earlier when I said that I could get rid of shell.nix files altogether.

I need to learn more about `use_nix` and getting environments from default.nix
files.
Diffstat (limited to 'zoo/shell.nix')
-rw-r--r--zoo/shell.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/zoo/shell.nix b/zoo/shell.nix
new file mode 100644
index 000000000000..04655ada8830
--- /dev/null
+++ b/zoo/shell.nix
@@ -0,0 +1,10 @@
+let
+  briefcase = import /home/wpcarro/briefcase {};
+in briefcase.buildHaskell.shell {
+  deps = hpkgs: with hpkgs; [
+    servant-server
+    aeson
+    warp
+    rio
+  ];
+}