about summary refs log tree commit diff
path: root/zoo/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-08-13T21·22+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-08-20T10·26+0100
commitf895cb417a7a397e9ddac7d2be7683e57e3cb1fb (patch)
tree7b1b5e6f68174bb86d6192e04348c92550ad334d /zoo/default.nix
parent3fdfa14355088af602877153b49a85a5941fe879 (diff)
Move shift-time into top-level //zoo
I'm still unsure whether or not this is a good idea, but experimenting is a good
way to find out!
Diffstat (limited to 'zoo/default.nix')
-rw-r--r--zoo/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/zoo/default.nix b/zoo/default.nix
new file mode 100644
index 0000000000..35de24d9c2
--- /dev/null
+++ b/zoo/default.nix
@@ -0,0 +1,21 @@
+{ briefcase, ... }:
+
+briefcase.buildHaskell.program {
+  name = "zoo";
+  srcs = builtins.path {
+    path = ./.;
+    name = "zoo-src";
+  };
+  ghcExtensions = [
+    "OverloadedStrings"
+    "NoImplicitPrelude"
+    "RecordWildCards"
+    "TypeApplications"
+  ];
+  deps = hpkgs: with hpkgs; [
+    servant-server
+    aeson
+    warp
+    rio
+  ];
+}