about summary refs log tree commit diff
path: root/xanthous.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2019-08-25T17·28-0400
committerGriffin Smith <root@gws.fyi>2019-08-25T17·28-0400
commitd3f3890dc5408581eb6181125c871d1cf2c0e18f (patch)
treeed6d9e396e6c732b1bce27ea6962ce408b59f218 /xanthous.nix
parentfb0d1b3e66251aa56a3df1d05fd4b82b33380a31 (diff)
An @-sign in a box, in haskell
Initial commit of a Haskell version of Xanthous, written using Brick and
built with Nix.

This is so much nicer and so much easier
Diffstat (limited to '')
-rw-r--r--xanthous.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/xanthous.nix b/xanthous.nix
new file mode 100644
index 0000000000..a10ed48305
--- /dev/null
+++ b/xanthous.nix
@@ -0,0 +1,29 @@
+{ mkDerivation, ascii-art-to-unicode, base, brick, classy-prelude
+, constraints, containers, data-default, deepseq, hpack, lens, mtl
+, QuickCheck, stdenv, tasty, tasty-hunit, tasty-quickcheck, vty
+}:
+let
+  pkgs = import <nixpkgs> {};
+  all-hies = import (fetchTarball "https://github.com/infinisil/all-hies/tarball/master") {};
+  hie = all-hies.selection { selector = p: { inherit (p) ghc865; }; };
+in
+mkDerivation {
+  pname = "xanthous";
+  version = "0.1.0.0";
+  src = ./.;
+  libraryHaskellDepends = [
+    ascii-art-to-unicode base brick classy-prelude constraints
+    containers data-default deepseq lens mtl QuickCheck vty
+  ];
+  libraryToolDepends = [ hpack ];
+  testHaskellDepends = [
+    ascii-art-to-unicode base brick classy-prelude constraints
+    containers data-default deepseq lens mtl QuickCheck tasty
+    tasty-hunit tasty-quickcheck
+  ];
+  executableSystemDepends = [ hie pkgs.cabal-install ];
+  preConfigure = "hpack";
+  homepage = "https://github.com/glittershark/xanthous#readme";
+  description = "A WIP TUI RPG";
+  license = stdenv.lib.licenses.gpl3;
+}