about summary refs log tree commit diff
path: root/xanthous.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2019-08-31T17·15-0400
committerGriffin Smith <root@gws.fyi>2019-08-31T17·15-0400
commit6eba471e2426e7e4e7d5c935e3ce973e13fd6b24 (patch)
treee7b41534bdd6b08fcd8c0e1c5444f3605e66cf09 /xanthous.nix
parentd3f3890dc5408581eb6181125c871d1cf2c0e18f (diff)
Use haskellSrc2nix over explicit cabal2nix
Use the (undocumented!) helper function haskellSrc2nix over having to
explicitly run cabal2nix all the time when rebuilding
Diffstat (limited to 'xanthous.nix')
-rw-r--r--xanthous.nix29
1 files changed, 0 insertions, 29 deletions
diff --git a/xanthous.nix b/xanthous.nix
deleted file mode 100644
index a10ed48305bb..000000000000
--- a/xanthous.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-{ mkDerivation, ascii-art-to-unicode, base, brick, classy-prelude
-, constraints, containers, data-default, deepseq, hpack, lens, mtl
-, QuickCheck, stdenv, tasty, tasty-hunit, tasty-quickcheck, vty
-}:
-let
-  pkgs = import <nixpkgs> {};
-  all-hies = import (fetchTarball "https://github.com/infinisil/all-hies/tarball/master") {};
-  hie = all-hies.selection { selector = p: { inherit (p) ghc865; }; };
-in
-mkDerivation {
-  pname = "xanthous";
-  version = "0.1.0.0";
-  src = ./.;
-  libraryHaskellDepends = [
-    ascii-art-to-unicode base brick classy-prelude constraints
-    containers data-default deepseq lens mtl QuickCheck vty
-  ];
-  libraryToolDepends = [ hpack ];
-  testHaskellDepends = [
-    ascii-art-to-unicode base brick classy-prelude constraints
-    containers data-default deepseq lens mtl QuickCheck tasty
-    tasty-hunit tasty-quickcheck
-  ];
-  executableSystemDepends = [ hie pkgs.cabal-install ];
-  preConfigure = "hpack";
-  homepage = "https://github.com/glittershark/xanthous#readme";
-  description = "A WIP TUI RPG";
-  license = stdenv.lib.licenses.gpl3;
-}