about summary refs log tree commit diff
path: root/website/sandbox/learnpianochords/src/server/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-08-09T21·11+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-08-09T21·11+0100
commit7d85ba559dd50e0552abccb45d1cf5766ebcb541 (patch)
tree0bb0df8da3cba69b31bb6b20b7c8717f87155e93 /website/sandbox/learnpianochords/src/server/shell.nix
parent26b7237aab8ec05526814be18603d18f537b3978 (diff)
Move Haskell-related shell.nix code into its own shell.nix
I'm getting tired of:

```shell
$ cd <project-root>
$ nix-shell
$ cd src/server
$ ghci Main.hs
```

Instead:

```shell
$ cd <project-root>/src/server
$ ghci Main.hs
```
Diffstat (limited to 'website/sandbox/learnpianochords/src/server/shell.nix')
-rw-r--r--website/sandbox/learnpianochords/src/server/shell.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/website/sandbox/learnpianochords/src/server/shell.nix b/website/sandbox/learnpianochords/src/server/shell.nix
new file mode 100644
index 000000000000..6cb5e19e99fa
--- /dev/null
+++ b/website/sandbox/learnpianochords/src/server/shell.nix
@@ -0,0 +1,19 @@
+let
+  pkgs = import /home/wpcarro/nixpkgs {};
+in pkgs.mkShell {
+  buildInputs = with pkgs; [
+    (haskellPackages.ghcWithPackages (hpkgs: [
+      hpkgs.hspec
+      hpkgs.servant-server
+      hpkgs.aeson
+      hpkgs.wai-cors
+      hpkgs.warp
+      hpkgs.jwt
+      hpkgs.unordered-containers
+      hpkgs.base64
+      hpkgs.http-conduit
+      hpkgs.rio
+      hpkgs.envy
+    ]))
+  ];
+}