about summary refs log tree commit diff
path: root/website/sandbox/learnpianochords/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-08-08T10·07+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-08-08T10·10+0100
commit7b8ec4170a04076d17e69160b30a9cf9091a3de8 (patch)
tree78f7e96d17e835e467cb80207fb60b208a550bec /website/sandbox/learnpianochords/shell.nix
parent9dcbd0d067b83d03956510faa26b96dff32007e4 (diff)
Begin work for supporting GoogleSignIn server-side
I'm attempting to be an obedient boy and implement this and future features
using TDD.

TL;DR:
- Defined a few tests
- Defined an empty GoogleSignIn module
- Defined a Fixtures module to quickly create JWTs to test
Diffstat (limited to 'website/sandbox/learnpianochords/shell.nix')
-rw-r--r--website/sandbox/learnpianochords/shell.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/website/sandbox/learnpianochords/shell.nix b/website/sandbox/learnpianochords/shell.nix
index ea5a404b33a0..9402ad5674d2 100644
--- a/website/sandbox/learnpianochords/shell.nix
+++ b/website/sandbox/learnpianochords/shell.nix
@@ -11,6 +11,10 @@ in pkgs.mkShell {
       hpkgs.aeson
       hpkgs.wai-cors
       hpkgs.warp
+      hpkgs.jwt
+      hpkgs.unordered-containers
+      hpkgs.base64
+      hpkgs.http-conduit
     ]))
   ];
 }