about summary refs log tree commit diff
path: root/website/sandbox/learnpianochords/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-08-17T09·08+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-08-20T10·26+0100
commit59f74814111045b6d74d2a8f5b4f4bfbd1cacd85 (patch)
treed87397c2b1f32bdc1d3df0ab4d4f62d1cf065426 /website/sandbox/learnpianochords/shell.nix
parent7833632a7961038e8898ef287fd2dedf8fa7f33b (diff)
Revise previous opinions about absolute paths GT <bracket-notation>
Unforeseen problem: `buildkite-agent` runs its builds in a separate directory,
so if I want the `nix-build` command to build the newly checked out code, I need
to set <briefcase> to the CWD.
Diffstat (limited to 'website/sandbox/learnpianochords/shell.nix')
-rw-r--r--website/sandbox/learnpianochords/shell.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/website/sandbox/learnpianochords/shell.nix b/website/sandbox/learnpianochords/shell.nix
index 6cc05d099177..1a9c967f7fea 100644
--- a/website/sandbox/learnpianochords/shell.nix
+++ b/website/sandbox/learnpianochords/shell.nix
@@ -1,5 +1,6 @@
 let
-  pkgs = import /home/wpcarro/nixpkgs {};
+  briefcase = import <briefcase> {};
+  pkgs = briefcase.third_party.pkgs;
 in pkgs.mkShell {
   buildInputs = with pkgs; [
     elmPackages.elm