about summary refs log tree commit diff
path: root/website/sandbox/learnpianochords/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-08-06T20·54+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-08-06T20·54+0100
commit1fc1087014a235a4fd153ea239ec3e5509757c17 (patch)
treeb55bc7a2dcbddf7a5819633fddbbb4cd9662b865 /website/sandbox/learnpianochords/shell.nix
parent5f52077492160195681a0a9bca806fd78ddbd6fd (diff)
Support Google Sign-in client-side
TODO: Support Google Sign-in server-side

Also:
- Add Haskell to project's shell.nix
- Add stubbed Main.hs and Spec.hs
- Add common .ghci file
Diffstat (limited to 'website/sandbox/learnpianochords/shell.nix')
-rw-r--r--website/sandbox/learnpianochords/shell.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/website/sandbox/learnpianochords/shell.nix b/website/sandbox/learnpianochords/shell.nix
index 6f1c8ee23b30..bf7a640fd1cf 100644
--- a/website/sandbox/learnpianochords/shell.nix
+++ b/website/sandbox/learnpianochords/shell.nix
@@ -1,9 +1,12 @@
 let
-  pkgs = import <nixpkgs> {};
+  pkgs = import /home/wpcarro/nixpkgs {};
 in pkgs.mkShell {
   buildInputs = with pkgs; [
     elmPackages.elm
     elmPackages.elm-format
     elmPackages.elm-live
+    (haskellPackages.ghcWithPackages (hpkgs: with hpkgs; [
+      hspec
+    ]))
   ];
 }