about summary refs log tree commit diff
path: root/website/sandbox/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-03-20T00·47+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-03-20T00·52+0000
commitf4fea2346e69235f8346ae626359fa1bf901282d (patch)
tree45e45ebc8b6bd70f213e625c904076642b7d5215 /website/sandbox/default.nix
parent1d5ab45303c700e188a1f041f6ff6630e96c7f03 (diff)
Move sandbox into website
Nest the sandbox work under ./website.
Diffstat (limited to 'website/sandbox/default.nix')
-rw-r--r--website/sandbox/default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/website/sandbox/default.nix b/website/sandbox/default.nix
new file mode 100644
index 000000000000..81cd5c212699
--- /dev/null
+++ b/website/sandbox/default.nix
@@ -0,0 +1,13 @@
+{ pkgs, briefcase, ... }:
+
+pkgs.stdenv.mkDerivation {
+  name = "covid-uk";
+  buildInputs = [];
+  src = ./.;
+  buildPhase = ''
+    mkdir -p $out
+    cp $src/index.html $out
+    cp -r ${briefcase.website.sandbox.covid-uk} $out/covid-uk
+  '';
+  dontInstall = true;
+}