about summary refs log tree commit diff
path: root/website/sandbox/covid-uk/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-07-02T12·28+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-07-02T12·28+0100
commite4ddc3ba75f75b6df0d11ccc62b75a346d0e3846 (patch)
treec2cac178e1085a9500f3b2d32fcab2058931d0f7 /website/sandbox/covid-uk/default.nix
parent155dff562ac5c9d893ace858c4a41a2d89955097 (diff)
Prefer builtins.path
Thanks to the Nix anti-patterns documented here...

https://nix.dev/anti-patterns/language.html#reproducability-referencing-top-level-directory-with

...I'm cleaning up some of my Nix expressions. Read the article for more
context.
Diffstat (limited to 'website/sandbox/covid-uk/default.nix')
-rw-r--r--website/sandbox/covid-uk/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/website/sandbox/covid-uk/default.nix b/website/sandbox/covid-uk/default.nix
index 0f5545c2f7..309b1fa64b 100644
--- a/website/sandbox/covid-uk/default.nix
+++ b/website/sandbox/covid-uk/default.nix
@@ -3,7 +3,7 @@
 pkgs.stdenv.mkDerivation {
   name = "covid-uk";
   buildInputs = [];
-  src = ./.;
+  src = builtins.path { path = ./.; name = "covid-uk"; };
   # TODO(wpcarro): Need to run `yarn install` somehow.
   # TODO(wpcarro): Need to run `npx tailwindcss build styles.css -o output.css`.
   buildPhase = ''