about summary refs log tree commit diff
path: root/website/sandbox/contentful/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-08-18T11·00+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-08-20T10·26+0100
commit0c71fc9d1d49daa914c0f56f4f9201d40415d9b4 (patch)
tree3c8a4b894065e64111c20d06026b63db17259c65 /website/sandbox/contentful/default.nix
parent51ec9e0d88b15276ec0891f932f6b572d6450809 (diff)
Drop support for dir-locals.nix, <nixpkgs>, etc.
In the spirit of Marie Kondo, I'm tidying up!

TL;DR:
- Prefer .envrc `use_nix` and delete all dir-locals.nix files
- Remove ~all references to <nixpkgs>, <unstable>, <depot> and prefer
  referencing each with briefcase.third_party.{pkgs,unstable,depot}
- Delete nixBufferFromShell function since I was only using that in
  dir-locals.nix files
Diffstat (limited to 'website/sandbox/contentful/default.nix')
-rw-r--r--website/sandbox/contentful/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/website/sandbox/contentful/default.nix b/website/sandbox/contentful/default.nix
index 00714f45d098..f7125655ccdc 100644
--- a/website/sandbox/contentful/default.nix
+++ b/website/sandbox/contentful/default.nix
@@ -1,6 +1,6 @@
-let
-  pkgs = import <nixpkgs> {};
-in pkgs.stdenv.mkDerivation {
+{ pkgs, ... }:
+
+pkgs.stdenv.mkDerivation {
   name = "ideal-website";
   src = builtins.path { path = ./.; name = "contentful"; };
   buildInputs = with pkgs; [