about summary refs log tree commit diff
path: root/website/goals/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-03-25T16·30+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-03-25T16·30+0000
commit89cd77a64b9146a88c75946fb0d9f2c5d6126821 (patch)
tree866f559e4150195e6446e3678e05597ec4875803 /website/goals/default.nix
parent265b691c9b076d61b1ed59a07b4a84ad6a74e020 (diff)
Create wpcarro.dev/goals
Create a simple React app to define my goals. See the goals/README.md for more
context.
Diffstat (limited to 'website/goals/default.nix')
-rw-r--r--website/goals/default.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/website/goals/default.nix b/website/goals/default.nix
new file mode 100644
index 000000000000..664e87a3c914
--- /dev/null
+++ b/website/goals/default.nix
@@ -0,0 +1,10 @@
+{ pkgs, ... }:
+
+pkgs.stdenv.mkDerivation {
+  name = "goals";
+  src = ./.;
+  installPhase = ''
+    mkdir -p $out
+    cp $srcs/index.{html,jsx} $out
+  '';
+}