about summary refs log tree commit diff
path: root/website/goals/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-03-25T17·18+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-03-25T17·18+0000
commit3ff6ae36975f1293229f27a4e60d1e1334ad6f77 (patch)
treed6ab35ee1f45b8c26d45b8d12b1e36d774d6a3fa /website/goals/default.nix
parent06d2467c56de10ee353b746992694365a17d526b (diff)
Use Parcel's --public-url option when building
By default Parcel prefixes output paths with /. So when Chrome loads
wpcarro.dev/goals it attempts to get the CSS and JS and other assets from
wpcarro.dev/ instead of wpcarro.dev/goals/. Using the --public-url ./ option
makes Parcel output relative paths, which should work better for my needs.
Diffstat (limited to 'website/goals/default.nix')
-rw-r--r--website/goals/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/website/goals/default.nix b/website/goals/default.nix
index 4337d3f0ce65..696b63375efb 100644
--- a/website/goals/default.nix
+++ b/website/goals/default.nix
@@ -11,7 +11,7 @@ pkgs.stdenv.mkDerivation {
   # parcel.js needs number of CPUs
   PARCEL_WORKERS = "1";
   buildPhase = ''
-    npx parcel build src/index.html
+    npx parcel build src/index.html --public-url ./
   '';
   installPhase = ''
     mv dist $out