about summary refs log tree commit diff
path: root/website/goals/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-03-25T17·04+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-03-25T17·04+0000
commit06d2467c56de10ee353b746992694365a17d526b (patch)
tree0c95bb8b7bf79f4b75eb5cd37c50e0be79bd53da /website/goals/default.nix
parentcd06990fe3cad2d3098bc1964f2b7185e4491cfa (diff)
Use boilerplate/typescript for goals
After deploying the version of this application that built everything in the
browser, which originally was the impetus for the entire project, I learned that
the babel in-browser transformer won't work. I'm not sure why, but I need to
move on from this project and do other work.

I ported the code to my boilerplate/typescript, which works. Wahoo!
Diffstat (limited to 'website/goals/default.nix')
-rw-r--r--website/goals/default.nix17
1 files changed, 13 insertions, 4 deletions
diff --git a/website/goals/default.nix b/website/goals/default.nix
index 664e87a3c914..4337d3f0ce65 100644
--- a/website/goals/default.nix
+++ b/website/goals/default.nix
@@ -1,10 +1,19 @@
 { pkgs, ... }:
 
 pkgs.stdenv.mkDerivation {
-  name = "goals";
-  src = ./.;
+  name = "goals-webpage";
+  srcs = ./.;
+  buildInputs = with pkgs; [
+    nodejs
+    # Exposes lscpu for parcel.js
+    utillinux
+  ];
+  # parcel.js needs number of CPUs
+  PARCEL_WORKERS = "1";
+  buildPhase = ''
+    npx parcel build src/index.html
+  '';
   installPhase = ''
-    mkdir -p $out
-    cp $srcs/index.{html,jsx} $out
+    mv dist $out
   '';
 }