about summary refs log tree commit diff
path: root/website/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-03-25T16·30+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-03-25T16·30+0000
commit89cd77a64b9146a88c75946fb0d9f2c5d6126821 (patch)
tree866f559e4150195e6446e3678e05597ec4875803 /website/default.nix
parent265b691c9b076d61b1ed59a07b4a84ad6a74e020 (diff)
Create wpcarro.dev/goals
Create a simple React app to define my goals. See the goals/README.md for more
context.
Diffstat (limited to 'website/default.nix')
-rw-r--r--website/default.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/website/default.nix b/website/default.nix
index 485f3af34a..2349b5cd9e 100644
--- a/website/default.nix
+++ b/website/default.nix
@@ -1,11 +1,13 @@
-{ pkgs, ... }:
+{ pkgs, briefcase, ... }:
 
 pkgs.stdenv.mkDerivation {
   name = "wpcarro.dev";
   src = ./.;
-  buildPhase = ''
+  installPhase = ''
     mkdir -p $out
     cp $src/index.html $out
+
+    mkdir -p $out/goals
+    cp -r ${briefcase.website.goals}/* $out/goals
   '';
-  dontInstall = true;
 }