about summary refs log tree commit diff
path: root/website/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-03-20T00·22+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-03-20T00·22+0000
commit54d1a0048a7101dc51bbea49feed7cded5031b17 (patch)
tree0e2eec03a79523cf2a3cb02939d36b6ccc7a230a /website/default.nix
parent76210a217c192bd832a2c57836f7a29c7b6c8908 (diff)
Add sitemap to wpcarro.dev
- Create ./website directory
- Add a sitemap to wpcarro.dev
- Move covid-uk directory to sandbox directory

TODO: Next sandbox, blog, and learn in the website directory
Diffstat (limited to 'website/default.nix')
-rw-r--r--website/default.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/website/default.nix b/website/default.nix
new file mode 100644
index 0000000000..485f3af34a
--- /dev/null
+++ b/website/default.nix
@@ -0,0 +1,11 @@
+{ pkgs, ... }:
+
+pkgs.stdenv.mkDerivation {
+  name = "wpcarro.dev";
+  src = ./.;
+  buildPhase = ''
+    mkdir -p $out
+    cp $src/index.html $out
+  '';
+  dontInstall = true;
+}