about summary refs log tree commit diff
path: root/web/tvixbolt/Cargo.toml
diff options
context:
space:
mode:
authorIlan Joselevich <personal@ilanjoselevich.com>2024-07-04T18·05+0300
committerIlan Joselevich <personal@ilanjoselevich.com>2024-07-05T20·19+0000
commit7ca32d9f0baf2548ec32d75d2872e8b82d4d8921 (patch)
tree791a20db7c7c1c3cc7da36088ac3b4f11af4f0c0 /web/tvixbolt/Cargo.toml
parent6a7069904e9d29f05638c37a52b640bc9eb43a63 (diff)
refactor(web/tvixbolt): buildRustPackage -> crate2nix r/8349
With the recent changes to crate2nix and buildRustCrate in nixpkgs it is
now possible to build tvixbolt via crate2nix like we do for other tvix
crates. We can reuse a lot of the customizations done in //tvix in
tvixbolt to avoid repeating ourselves.

A script for serving tvixbolt locally for testing purposes is also
available now through the .serve attribute of tvixbolt.

This change supersedes https://cl.tvl.fyi/c/depot/+/11821.

Change-Id: I4864df8b75aec73cf5fee2428924ed4cfbb32902
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11952
Tested-by: BuildkiteCI
Autosubmit: Ilan Joselevich <personal@ilanjoselevich.com>
Reviewed-by: flokli <flokli@flokli.de>
Diffstat (limited to 'web/tvixbolt/Cargo.toml')
-rw-r--r--web/tvixbolt/Cargo.toml25
1 files changed, 7 insertions, 18 deletions
diff --git a/web/tvixbolt/Cargo.toml b/web/tvixbolt/Cargo.toml
index dafbe5ad60a9..e25267d3b961 100644
--- a/web/tvixbolt/Cargo.toml
+++ b/web/tvixbolt/Cargo.toml
@@ -3,24 +3,13 @@ name = "tvixbolt"
 version = "0.1.0"
 edition = "2021"
 
+[lib]
+crate-type = ["cdylib"]
+
 [dependencies]
 yew = "0.19.3"
 yew-router = "0.16"
-codemap = "0.1.3"
-serde_urlencoded = "*" # pinned by yew
-rnix = "0.11.0"
-
-# needs to be in sync with nixpkgs
-wasm-bindgen = "= 0.2.92"
-
-[dependencies.tvix-eval]
-path = "../../tvix/eval"
-default-features = false
-
-[dependencies.serde]
-version = "*" # pinned by yew
-features = [ "derive" ]
-
-[dependencies.web-sys]
-version = "*" # pinned by yew
-features = [ "HtmlDetailsElement" ]
+tvix-eval = { path = "../../tvix/eval", default-features = false }
+serde = { version = "1.0.203", features = ["derive"] }
+web-sys = { version = "0.3.69", features = ["HtmlDetailsElement"] }
+wasm-bindgen = "0.2.92"