about summary refs log tree commit diff
path: root/web/tazblog_lisp/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-01-27T02·11+0000
committerVincent Ambo <tazjin@google.com>2020-01-27T02·11+0000
commit176b3458b0352975dfa1af7eac5cb90a5394a4ba (patch)
tree323b1d93b175c240fb45a4f0e95a8f1b4980e12b /web/tazblog_lisp/default.nix
parentdba2e5426e8951bcd22a28f28e7bb4493ee9eda8 (diff)
feat(web/tazblog_lisp): Implement retrieval of blog posts from DNS r/468
This is mostly equivalent to the Haskell implementation, with the
primary difference that the Lisp DNS library does not support caching
yet.
Diffstat (limited to 'web/tazblog_lisp/default.nix')
-rw-r--r--web/tazblog_lisp/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/web/tazblog_lisp/default.nix b/web/tazblog_lisp/default.nix
new file mode 100644
index 000000000000..178c731ccb75
--- /dev/null
+++ b/web/tazblog_lisp/default.nix
@@ -0,0 +1,21 @@
+{ pkgs, ... }:
+
+pkgs.nix.buildLisp.library {
+  name = "tazblog";
+
+  deps =
+  # Local dependencies
+  (with pkgs.lisp; [ dns ])
+
+  # Third-party dependencies
+  ++ (with pkgs.third_party.lisp; [
+    cl-base64
+    cl-json
+    hunchentoot
+    iterate
+  ]);
+
+  srcs = [
+    ./store.lisp
+  ];
+}