about summary refs log tree commit diff
path: root/web/panettone/default.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-07-28T04·31-0400
committerglittershark <grfn@gws.fyi>2020-07-31T02·05+0000
commit8e7ba41a3486a53de139486b75d72a349d13c415 (patch)
treec4f4cf72e6d34075448071ec31033d34b8cafd3c /web/panettone/default.nix
parent14a8142f7611378195234895aaa172983b6d5a10 (diff)
feat(web/panettone): Log when users change issue statuses r/1509
Log in the database, in a way that will generalize to tracking edit
history as well, when users change the status of an issue. To facilitate
easily knowing who is currently authenticated (without introducing a
circular dependency) the authentication-relaated code has also been
factored out into its own package, which is nice because we want to
replace that sooner rather than later anyway.

Fixes: #13
Change-Id: I65a544fab660ed1c295ee8f6b293e0d4945a8203
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1496
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'web/panettone/default.nix')
-rw-r--r--web/panettone/default.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/web/panettone/default.nix b/web/panettone/default.nix
index 637ccfea9d..4d40209231 100644
--- a/web/panettone/default.nix
+++ b/web/panettone/default.nix
@@ -22,7 +22,21 @@ depot.nix.buildLisp.program {
     ./src/packages.lisp
     ./src/util.lisp
     ./src/css.lisp
+    ./src/authentication.lisp
     ./src/model.lisp
     ./src/panettone.lisp
   ];
+
+  tests = {
+    deps = with depot.third_party.lisp; [
+      fiveam
+    ];
+
+    srcs = [
+      ./test/package.lisp
+      ./test/model_test.lisp
+    ];
+
+    expression = "(fiveam:run!)";
+  };
 }