about summary refs log tree commit diff
path: root/web/homepage/nginx.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-02-09T00·01+0000
committerVincent Ambo <tazjin@google.com>2020-02-09T00·01+0000
commit39854d71b2afa5e793acb6a76f30b038bf569cca (patch)
tree8dce2bdbbc3dd144b4d501989a5f07803bfe3f93 /web/homepage/nginx.nix
parente6002f95cd3ad5c4ee449e6a51c50f07da26f287 (diff)
refactor(web): Serve static assets to //web/homepage r/490
Shuffles around the nginx locations that are served to ensure that all
static content will be served from tazj.in/static (including for the
blog).
Diffstat (limited to '')
-rw-r--r--web/homepage/nginx.nix12
1 files changed, 5 insertions, 7 deletions
diff --git a/web/homepage/nginx.nix b/web/homepage/nginx.nix
index 90a13a1e98..33b89ee7cc 100644
--- a/web/homepage/nginx.nix
+++ b/web/homepage/nginx.nix
@@ -6,7 +6,7 @@
   writeText, writeShellScriptBin, nginx, lib,
 
   # website content
-  blog
+  blog, website
 }:
 
 let
@@ -44,15 +44,13 @@ let
 
       server {
         listen 8080 default_server;
-        root ${blog.rendered};
-
-        location /static {
-          alias ${blog.static}/;
-        }
+        root ${website};
 
         ${oldRedirects}
 
-        location / {
+        location /blog {
+          alias ${blog.rendered};
+
           if ($request_uri ~ ^/(.*)\.html$) {
             return 302 /$1;
           }