about summary refs log tree commit diff
path: root/web/homepage/nginx.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-02-09T00·30+0000
committerVincent Ambo <tazjin@google.com>2020-02-09T00·30+0000
commit0fd762e2d020cb78d283235518a06b3d556ad985 (patch)
tree37b8dfb384a86ccd1e06e6016f725b3f34c78d3b /web/homepage/nginx.nix
parent69b6ff26c340305ba5abf13ef294e1533388cf09 (diff)
fix(web/homepage): Ensure old blog links keep working r/494
Diffstat (limited to '')
-rw-r--r--web/homepage/nginx.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/web/homepage/nginx.nix b/web/homepage/nginx.nix
index 33b89ee7cc..011f48d51b 100644
--- a/web/homepage/nginx.nix
+++ b/web/homepage/nginx.nix
@@ -14,9 +14,9 @@ let
   inherit (pkgs.third_party) ;
 
   oldRedirects = lib.concatStringsSep "\n" (map (post: ''
-    location ~* ^(en)?/${post.oldKey} {
+    location ~* ^(/en)?/${post.oldKey} {
       # TODO(tazjin): 301 once this works
-      return 302 /${post.key};
+      return 302 /blog/${post.key};
     }
   '') (filter (hasAttr "oldKey") blog.posts));