about summary refs log tree commit diff
path: root/web/homepage/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-02-11T19·31+0000
committerVincent Ambo <tazjin@google.com>2020-02-11T19·31+0000
commitb5c50f4699ad5dd18b247b77719aa188b0003430 (patch)
tree99c61b3c4b1876d8f3fde79f3e7e1b042fa92e2a /web/homepage/default.nix
parent2e958227122717ae5a013fd4656664d28d20f00d (diff)
refactor(web): Let //web/ derivations build static pages only r/539
Removes nginx configuration built by the web targets (with the
exception of the includable block used to set up redirects for old
blog URLs).
Diffstat (limited to 'web/homepage/default.nix')
-rw-r--r--web/homepage/default.nix14
1 files changed, 5 insertions, 9 deletions
diff --git a/web/homepage/default.nix b/web/homepage/default.nix
index d2905a7eb6..3c1e75f8f3 100644
--- a/web/homepage/default.nix
+++ b/web/homepage/default.nix
@@ -65,12 +65,8 @@ let
   ));
 
   homepage = index ((map postToEntry web.blog.posts) ++ (import ./entries.nix));
-  website = runCommandNoCC "website" {} ''
-    mkdir $out
-    cp ${homepage} $out/index.html
-    cp -r ${./static} $out/static
-  '';
-in third_party.callPackage ./nginx.nix {
-  inherit website;
-  blog = web.blog;
-}
+in runCommandNoCC "website" {} ''
+  mkdir $out
+  cp ${homepage} $out/index.html
+  cp -r ${./static} $out/static
+''