about summary refs log tree commit diff
path: root/web/converse/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-04-05T15·22+0200
committertazjin <mail@tazj.in>2021-04-05T19·19+0000
commita0c4b91955662297ec5bd9249a9488ea6d52defc (patch)
treeda1423cb0b9552ed2215628e449928b3dcc159bf /web/converse/default.nix
parent5387cc9e7d7ef5ca9ecaeea46132510298902769 (diff)
fix(web/converse): Bare minimum changes to build in 2021 r/2443
This project depends on Tokio, via actix, and both of those are bad
ideas. This wasn't as clear 3 years ago as it is now, but to
demonstrate it the project has amassed issues which required at least
this minimum of changes to be buildable in 2021 (using a modern
rustc).

Yes, this adds dozens of new dependencies again (because of a
top-level update) but don't worry: They will be gone when I'm done
here.

Change-Id: I1dde9dc0325da7bdcb6608359fab33e27692dc1d
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2857
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'web/converse/default.nix')
-rw-r--r--web/converse/default.nix21
1 files changed, 5 insertions, 16 deletions
diff --git a/web/converse/default.nix b/web/converse/default.nix
index 24d24cf035..a750671196 100644
--- a/web/converse/default.nix
+++ b/web/converse/default.nix
@@ -1,18 +1,7 @@
-# This Nix derivation imports the generated Carnix sources and builds
-# Converse.
-#
-# To work around an issue in Carnix ([1] & [2]) the attributes of the
-# comrak crate have been overridden with a dummy environment variable
-# to simulate a Cargo-based build. This requires a manual change to
-# `Cargo.nix` when updating dependencies.
-#
-# [1]: https://nest.pijul.com/pmeunier/carnix/discussions/2
-# [2]: https://nest.pijul.com/pmeunier/carnix/discussions/3
+{ pkgs, ... }:
 
-{ pkgs ? import <nixpkgs> {}, ... }:
-
-let cargo = pkgs.callPackage ./Cargo.nix {};
-in {
-  # Build is not yet fixed up for the depot.
-  meta.ci = false;
+pkgs.naersk.buildPackage {
+  src = ./.;
+  buildInputs = with pkgs; [ openssl postgresql.lib ];
+  nativeBuildInputs = [ pkgs.pkgconfig ];
 }