about summary refs log tree commit diff
path: root/web/converse/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-04-05T14·55+0200
committerVincent Ambo <mail@tazj.in>2021-04-05T15·01+0200
commit8142149e28991b15affc5e4576a033e0ada9778b (patch)
tree44387ac5cae9c3a39e1810909ef2ee92e0278709 /web/converse/default.nix
parent386afdc794eefd5bcbc47a3fd7b898a07f69f978 (diff)
parent09168021e7405f6b83798d0b43aa6e69e744ae87 (diff)
feat(web/converse): Import repository r/2440
Imports the converse forum software I wrote a few years ago. I want to
clean this up a bit and try using Hotwire with it.

Note: The original repository was AGPL-3.0 licensed. I'm the copyright
holder and have relicensed it to GPL-3.0 in the commit that is being
merged.

Imported from: https://github.com/tazjin/converse

git-subtree-dir: web/converse
git-subtree-mainline: 386afdc794eefd5bcbc47a3fd7b898a07f69f978
git-subtree-split: 09168021e7405f6b83798d0b43aa6e69e744ae87
Change-Id: Ia8b587db5174ef5b3c52910d3d027199150c58e0
Diffstat (limited to 'web/converse/default.nix')
-rw-r--r--web/converse/default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/web/converse/default.nix b/web/converse/default.nix
new file mode 100644
index 0000000000..24d24cf035
--- /dev/null
+++ b/web/converse/default.nix
@@ -0,0 +1,18 @@
+# This Nix derivation imports the generated Carnix sources and builds
+# Converse.
+#
+# To work around an issue in Carnix ([1] & [2]) the attributes of the
+# comrak crate have been overridden with a dummy environment variable
+# to simulate a Cargo-based build. This requires a manual change to
+# `Cargo.nix` when updating dependencies.
+#
+# [1]: https://nest.pijul.com/pmeunier/carnix/discussions/2
+# [2]: https://nest.pijul.com/pmeunier/carnix/discussions/3
+
+{ pkgs ? import <nixpkgs> {}, ... }:
+
+let cargo = pkgs.callPackage ./Cargo.nix {};
+in {
+  # Build is not yet fixed up for the depot.
+  meta.ci = false;
+}