about summary refs log tree commit diff
path: root/web/converse/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-04-05T14·55+0200
committerVincent Ambo <mail@tazj.in>2021-04-05T15·01+0200
commit8142149e28991b15affc5e4576a033e0ada9778b (patch)
tree44387ac5cae9c3a39e1810909ef2ee92e0278709 /web/converse/Cargo.toml
parent386afdc794eefd5bcbc47a3fd7b898a07f69f978 (diff)
parent09168021e7405f6b83798d0b43aa6e69e744ae87 (diff)
feat(web/converse): Import repository r/2440
Imports the converse forum software I wrote a few years ago. I want to
clean this up a bit and try using Hotwire with it.

Note: The original repository was AGPL-3.0 licensed. I'm the copyright
holder and have relicensed it to GPL-3.0 in the commit that is being
merged.

Imported from: https://github.com/tazjin/converse

git-subtree-dir: web/converse
git-subtree-mainline: 386afdc794eefd5bcbc47a3fd7b898a07f69f978
git-subtree-split: 09168021e7405f6b83798d0b43aa6e69e744ae87
Change-Id: Ia8b587db5174ef5b3c52910d3d027199150c58e0
Diffstat (limited to 'web/converse/Cargo.toml')
-rw-r--r--web/converse/Cargo.toml35
1 files changed, 35 insertions, 0 deletions
diff --git a/web/converse/Cargo.toml b/web/converse/Cargo.toml
new file mode 100644
index 0000000000..ddba316a9e
--- /dev/null
+++ b/web/converse/Cargo.toml
@@ -0,0 +1,35 @@
+[package]
+name = "converse"
+version = "0.1.0"
+authors = ["Vincent Ambo <mail@tazj.in>"]
+license = "AGPL-3.0-or-later"
+
+[dependencies]
+actix = "0.5"
+actix-web = "0.6"
+askama = "0.6"
+chrono = { version = "0.4", features = ["serde"] }
+comrak = "0.2"
+diesel = { version = "1.2", features = ["postgres", "chrono", "r2d2"]}
+env_logger = "0.5"
+failure = "0.1"
+futures = "0.1"
+hyper = "0.11"
+log = "0.4"
+md5 = "0.3.7"
+mime_guess = "2.0.0-alpha"
+pq-sys = "=0.4.4"
+r2d2 = "0.8"
+rand = "0.4"
+reqwest = "0.8"
+serde = "1.0"
+serde_derive = "1.0"
+serde_json = "1.0"
+tokio = "0.1"
+tokio-timer = "0.2"
+url = "1.7"
+url_serde = "0.2"
+
+[build-dependencies]
+pulldown-cmark = "0.1"
+askama = "0.6"