about summary refs log tree commit diff
path: root/web/converse/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-04-05T15·22+0200
committertazjin <mail@tazj.in>2021-04-05T19·19+0000
commita0c4b91955662297ec5bd9249a9488ea6d52defc (patch)
treeda1423cb0b9552ed2215628e449928b3dcc159bf /web/converse/Cargo.toml
parent5387cc9e7d7ef5ca9ecaeea46132510298902769 (diff)
fix(web/converse): Bare minimum changes to build in 2021 r/2443
This project depends on Tokio, via actix, and both of those are bad
ideas. This wasn't as clear 3 years ago as it is now, but to
demonstrate it the project has amassed issues which required at least
this minimum of changes to be buildable in 2021 (using a modern
rustc).

Yes, this adds dozens of new dependencies again (because of a
top-level update) but don't worry: They will be gone when I'm done
here.

Change-Id: I1dde9dc0325da7bdcb6608359fab33e27692dc1d
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2857
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'web/converse/Cargo.toml')
-rw-r--r--web/converse/Cargo.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/web/converse/Cargo.toml b/web/converse/Cargo.toml
index ddba316a9e..5ace4dabe1 100644
--- a/web/converse/Cargo.toml
+++ b/web/converse/Cargo.toml
@@ -2,11 +2,11 @@
 name = "converse"
 version = "0.1.0"
 authors = ["Vincent Ambo <mail@tazj.in>"]
-license = "AGPL-3.0-or-later"
+license = "GPL-3.0"
 
 [dependencies]
-actix = "0.5"
-actix-web = "0.6"
+actix = "0.7"
+actix-web = "0.7"
 askama = "0.6"
 chrono = { version = "0.4", features = ["serde"] }
 comrak = "0.2"
@@ -21,7 +21,7 @@ mime_guess = "2.0.0-alpha"
 pq-sys = "=0.4.4"
 r2d2 = "0.8"
 rand = "0.4"
-reqwest = "0.8"
+reqwest = "0.9"
 serde = "1.0"
 serde_derive = "1.0"
 serde_json = "1.0"