about summary refs log tree commit diff
path: root/web/blog/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@tvl.su>2023-09-08T12·50+0300
committertazjin <tazjin@tvl.su>2023-09-08T13·51+0000
commita32730ab45a9acb8871e3a9a5a68098047f4a145 (patch)
tree3f162a6a816563ed91f395ec9dd6c96fb7731e6e /web/blog/default.nix
parentc5770e65dd2dd82509da245cd6afc3077bca7d2b (diff)
feat(web/blog): add option to disable tagfilter per-post r/6566
Posts can now specify (optionally) tagfilter=true/false to toggle
escaping of HTML tags.

Change-Id: Ie4a1a45028570fc166fdffba708bf9d0e0c6ae81
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9277
Tested-by: BuildkiteCI
Reviewed-by: Mark Shevchenko <markshevchenko@gmail.com>
Diffstat (limited to 'web/blog/default.nix')
-rw-r--r--web/blog/default.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/web/blog/default.nix b/web/blog/default.nix
index 66d7759deb..696a9529c3 100644
--- a/web/blog/default.nix
+++ b/web/blog/default.nix
@@ -24,6 +24,10 @@ let
     # Path to the Markdown file containing the post content.
     content = path;
 
+    # Whether dangerous HTML tags should be filtered in this post. Can
+    # be disabled to, for example, embed videos in a post.
+    tagfilter = option bool;
+
     # Optional name of the author to display.
     author = option string;