about summary refs log tree commit diff
path: root/web/blog/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-02-08T13·33+0000
committerVincent Ambo <tazjin@google.com>2020-02-08T13·33+0000
commit15b871806b5ceb0a1c6f563e02c1ef79ee761412 (patch)
tree30677d52497736f71858b7d722b74f662c2dfff3 /web/blog/default.nix
parent1d7b1334fd4c2a9aff678891ce5f305be21e5c95 (diff)
feat(web/blog): Add Nix-based static blog generator r/484
This introduces a derivation which builds an instance of nginx
statically serving my blog posts, though as of now no indexes are
being generated and no XML feed is available.

This is just the initial draft of this setup and not yet what shall be
yielded in the end.
Diffstat (limited to 'web/blog/default.nix')
-rw-r--r--web/blog/default.nix46
1 files changed, 46 insertions, 0 deletions
diff --git a/web/blog/default.nix b/web/blog/default.nix
new file mode 100644
index 0000000000..bc7b9666f7
--- /dev/null
+++ b/web/blog/default.nix
@@ -0,0 +1,46 @@
+# This creates the static files that make up my blog from the Markdown
+# files in this repository.
+#
+# All blog posts are rendered from Markdown by cheddar.
+{ pkgs, lib, ... }@args:
+
+with pkgs.nix.yants;
+
+let
+  # Type definition for a single blog post.
+  post = struct "blog-post" {
+    key = string; #
+    title = string;
+    date = string; # *sigh*
+
+    # Path to the Markdown file containing the post content.
+    content = path;
+
+    # Should this post be included in the index? (defaults to true)
+    listed = option bool;
+
+    # Is this a draft? (adds a banner indicating that the link should
+    # not be shared)
+    draft = option bool;
+
+    # Previously each post title had a numeric ID. For these numeric
+    # IDs, redirects are generated so that old URLs stay compatible.
+    oldKey = option string;
+  };
+
+  posts = list post (import ./posts.nix);
+  fragments = import ./fragments.nix args;
+
+  renderedBlog = pkgs.third_party.runCommandNoCC "tazjins-blog" {} ''
+    mkdir -p $out
+
+    cp ${fragments.blogIndex posts} $out/index.html
+
+    ${lib.concatStringsSep "\n" (map (post:
+      "cp ${fragments.renderPost post} $out/${post.key}.html"
+    ) posts)}
+  ''; # '' (this line makes nix-mode happy :/)
+
+in import ./nginx.nix (args // {
+  inherit posts renderedBlog;
+})