about summary refs log tree commit diff
path: root/views/kit/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-06-07T09·34+0000
committerclbot <clbot@tvl.fyi>2022-06-07T09·40+0000
commitd8583088b868b97ea58f3763c9c99b3ba552ecea (patch)
treea214a991378fd914a597458d4e48394cf4b6093b /views/kit/default.nix
parent8e8d6eb1dfb51aeb0f2392bc7bc2e2a7b7ca9522 (diff)
feat(tvl-kit): Expose //tools/checks in tvl-kit r/4228
This makes CI utility functions available in TVL kit. For now this is
only the Terraform check, but said check has come up in other repos
before so it's useful to centralise here (and we might add more!)

Change-Id: I18acb19fc3407650ab9bad53dfba022dda498c07
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5858
Autosubmit: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Reviewed-by: asmundo <asmundo@gmail.com>
Diffstat (limited to 'views/kit/default.nix')
-rw-r--r--views/kit/default.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/views/kit/default.nix b/views/kit/default.nix
index 47c6088a46..b2ff2a595f 100644
--- a/views/kit/default.nix
+++ b/views/kit/default.nix
@@ -25,6 +25,7 @@ pkgs.lib.fix (self: {
     depot.nix.readTree = self.readTree;
   };
 
+  checks = import ./checks { inherit pkgs; };
   lazy-deps = import ./lazy-deps { inherit pkgs; };
   magrathea = import ./magrathea { inherit pkgs; };
   readTree = import ./readTree { };