about summary refs log tree commit diff
path: root/utils/fs.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-09-01T11·16+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-09-01T11·16+0100
commita0760279452b128ef815b0492489b6d550156f0a (patch)
tree86e4aa8f0509975f5148f4c40d20172aa8a88cc0 /utils/fs.nix
parentfb5ec068ddd50f6bce41c7a0bad45673db787940 (diff)
Define {builder,fs}.nix for utils.nix
Re-export everything from utils.nix.
Diffstat (limited to 'utils/fs.nix')
-rw-r--r--utils/fs.nix41
1 files changed, 41 insertions, 0 deletions
diff --git a/utils/fs.nix b/utils/fs.nix
new file mode 100644
index 000000000000..6305e705b141
--- /dev/null
+++ b/utils/fs.nix
@@ -0,0 +1,41 @@
+{ pkgs, ... }:
+
+# `fs` contains utility functions for working with the filesystem.
+
+let
+  inherit (builtins) attrNames hasAttr map readDir;
+  inherit (pkgs.lib) filterAttrs;
+in {
+  # Returns a list of all of the regular files in `dir`.
+  files = dir:
+    map (name: dir + "/${name}")
+      (attrNames
+        (filterAttrs (_: type: type == "regular") (readDir dir)));
+
+  # Returns a list of all of the directories in `dir`.
+  dirs = dir:
+    map (name: dir + "/${name}")
+      (attrNames
+        (filterAttrs (_: type: type == "directory") (readDir dir)));
+
+  # Returns a list of paths to all of the `name` files starting at `dir`.
+  find = name: dir:
+    if hasAttr name (readDir dir) then
+      [ (dir + name) ] ++ concatMap findAllDefaultNix (dirs dir)
+    else
+      concatMap findAllDefaultNix (dirs dir);
+
+  # Looks for `name` in `dir`; if it cannot find it, it checks the parent
+  # directory.
+  resolve = name: dir:
+    if hasAttr name (readDir dir) then
+      dir + "/${name}"
+    else
+      # This prevents the function from infinitely recursing and eventually
+      # stack overflowing.
+      if (dirOf dir) == dir then
+        null
+      else
+        resolve name (dirOf dir);
+  };
+}