about summary refs log tree commit diff
path: root/utils/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-09-01T11·16+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-09-01T11·16+0100
commita0760279452b128ef815b0492489b6d550156f0a (patch)
tree86e4aa8f0509975f5148f4c40d20172aa8a88cc0 /utils/default.nix
parentfb5ec068ddd50f6bce41c7a0bad45673db787940 (diff)
Define {builder,fs}.nix for utils.nix
Re-export everything from utils.nix.
Diffstat (limited to 'utils/default.nix')
-rw-r--r--utils/default.nix22
1 files changed, 11 insertions, 11 deletions
diff --git a/utils/default.nix b/utils/default.nix
index df9673daec70..db01702a1fec 100644
--- a/utils/default.nix
+++ b/utils/default.nix
@@ -1,14 +1,14 @@
-{ pkgs, ... }:
+args@{ pkgs, ... }:
 
-# Using this as a library to define some common utility functions that I often
-# reach for.
-{
-  # A unary function that returns its argument.
-  identity = x: x;
+# This top-level module exposes all of my utility functions for Nix. It should
+# be used like:
+# ```nix
+# inherit (briefcase.utils) fs;
+# ```
 
-  # Create a derivation that creates an executable shell script named `as` that
-  # calls the program located at `path`, forwarding all of the arguments.
-  wrapNonNixProgram = { path, as }: pkgs.writeShellScriptBin as ''
-    exec ${path} "$@"
-  '';
+let
+  builder = import ./builder.nix args;
+  fs      = import ./fs.nix args;
+in {
+  inherit builder fs;
 }