about summary refs log tree commit diff
path: root/users/zseri/store-ref-scanner/fuzz/Cargo.toml
diff options
context:
space:
mode:
authorzseri <zseri.devel@ytrizja.de>2021-12-25T02·17+0100
committerzseri <zseri.devel@ytrizja.de>2021-12-25T05·03+0000
commitf4dddea4c375dd0dc472d8879cc4fc506dd77d8c (patch)
tree544f2b746743d35501d978396fe6ba5ad53dbdf2 /users/zseri/store-ref-scanner/fuzz/Cargo.toml
parent5f2b37bdb07f5b931ac555939710ce681472e04d (diff)
fix(zseri/store-ref-scanner): no_std support and runtime panics r/3385
This also changes the fuzzing infrastructure from proptest to cargo-fuzz,
and this lead to the discovery of two mishandlings of edge-cases:

* when a "path_to_store" is at the end of the input, it tried to access
  the input slice out-of-bounds (the `just_store` test covers that now)
* non-ASCII characters lead to an out-of-bounds access in HalfBytesMask
  (the `non_ascii` test covers that now)

Change-Id: Icaa2518dcd93e1789a2c0da4cf0fec46016d3bad
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4604
Tested-by: BuildkiteCI
Reviewed-by: zseri <zseri.devel@ytrizja.de>
Diffstat (limited to 'users/zseri/store-ref-scanner/fuzz/Cargo.toml')
-rw-r--r--users/zseri/store-ref-scanner/fuzz/Cargo.toml31
1 files changed, 31 insertions, 0 deletions
diff --git a/users/zseri/store-ref-scanner/fuzz/Cargo.toml b/users/zseri/store-ref-scanner/fuzz/Cargo.toml
new file mode 100644
index 0000000000..baa1713275
--- /dev/null
+++ b/users/zseri/store-ref-scanner/fuzz/Cargo.toml
@@ -0,0 +1,31 @@
+[package]
+name = "store-ref-scanner-fuzz"
+version = "0.0.0"
+authors = ["Automatically generated"]
+publish = false
+edition = "2018"
+
+[package.metadata]
+cargo-fuzz = true
+
+[dependencies]
+libfuzzer-sys = "0.4"
+
+[dependencies.store-ref-scanner]
+path = ".."
+
+# Prevent this from interfering with workspaces
+[workspace]
+members = ["."]
+
+[[bin]]
+name = "hbm-roundtrip"
+path = "fuzz_targets/hbm-roundtrip.rs"
+test = false
+doc = false
+
+[[bin]]
+name = "nocrash"
+path = "fuzz_targets/nocrash.rs"
+test = false
+doc = false