about summary refs log tree commit diff
path: root/users/zseri/store-ref-scanner/Cargo.toml
diff options
context:
space:
mode:
authorzseri <zseri.devel@ytrizja.de>2021-12-24T19·29+0100
committerzseri <zseri.devel@ytrizja.de>2021-12-25T01·22+0000
commit8cdda57580bb1b4fdb19091c45b437f6327d78c0 (patch)
tree388c06ee055193835fcab0a7791fbd6a40dc49d2 /users/zseri/store-ref-scanner/Cargo.toml
parent979502335b8130599a89e2b3f91aaa974aa6dfe5 (diff)
feat(zseri): Add store-ref-scanner crate r/3383
This crate implements the scanner for finding references to store
paths in uncompressed binary blobs and text files.
It is currently a minimally working prototype and
it is probably a good idea to polish the interface further.

Change-Id: I8406f9d52d254fc3d660ea2b9bc9b7841cc815ec
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4596
Tested-by: BuildkiteCI
Reviewed-by: zseri <zseri.devel@ytrizja.de>
Diffstat (limited to 'users/zseri/store-ref-scanner/Cargo.toml')
-rw-r--r--users/zseri/store-ref-scanner/Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/users/zseri/store-ref-scanner/Cargo.toml b/users/zseri/store-ref-scanner/Cargo.toml
new file mode 100644
index 000000000000..c73b517374ca
--- /dev/null
+++ b/users/zseri/store-ref-scanner/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "store-ref-scanner"
+version = "0.1.0"
+edition = "2021"
+
+[dependencies]
+camino = "1.0"
+once_cell = "1.9.0"
+proc_unroll = "0.1"
+
+[dev-dependencies]
+
+[dev-dependencies.proptest]
+version = "1.0"
+default-features = false
+features = ["std"]