about summary refs log tree commit diff
path: root/users/wpcarro/scratch/rust/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2022-09-01T16·53-0700
committerclbot <clbot@tvl.fyi>2022-09-06T18·09+0000
commitdb9cb70d5d7807adff255e21a04d78c5700d1260 (patch)
tree722ba88d423735841fe0c4d9358310ee7c6164ea /users/wpcarro/scratch/rust/shell.nix
parente23a55687374d81bb55380081f137873222437f4 (diff)
feat(wpcarro/rust): Define Rc<T> example r/4687
My foray into "smart pointer" land.

Change-Id: I4ca775c72168dd34d90bf88fa41149867cd7fdae
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6244
Tested-by: BuildkiteCI
Reviewed-by: wpcarro <wpcarro@gmail.com>
Autosubmit: wpcarro <wpcarro@gmail.com>
Diffstat (limited to 'users/wpcarro/scratch/rust/shell.nix')
-rw-r--r--users/wpcarro/scratch/rust/shell.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/users/wpcarro/scratch/rust/shell.nix b/users/wpcarro/scratch/rust/shell.nix
index 064e7d8bb38a..98e2dbf4b29b 100644
--- a/users/wpcarro/scratch/rust/shell.nix
+++ b/users/wpcarro/scratch/rust/shell.nix
@@ -1,4 +1,4 @@
-{ pkgs, ... }:
+{ pkgs ? import <nixpkgs> { }, ... }:
 
 pkgs.mkShell {
   buildInputs = [